Home / Android Apps / Google Translate Apk

Google Translate Apk

Google Translate Apk

* Type to translate 90 languages
* Use your camera to translate text instantly in 26 languages
* Two-way automatic speech translation in 40 languages
* Draw with your finger as a keyboard alternative
* Download language packs for when you’re traveling, or if your connection is expensive or slow.
* Star and save translations for future reference
* Take pictures of text for higher-quality translations or for languages not supported by instant camera translation

Some features not available in all languages.

Translations between the following languages are supported:
Afrikaans, Albanian, Arabic, Armenian, Azerbaijani, Basque, Belarusian, Bengali, Bosnian, Bulgarian, Catalan, Cebuano, Chichewa, Chinese (Simplified), Chinese (Traditional), Croatian, Czech, Danish, Dutch, English, Esperanto, Estonian, Filipino, Finnish, French, Galician, Georgian, German, Greek, Gujarati, Haitian Creole, Hausa, Hebrew, Hindi, Hmong, Hungarian, Icelandic, Igbo, Indonesian, Irish, Italian, Japanese, Javanese, Kannada, Kazakh, Khmer, Korean, Lao, Latin, Latvian, Lithuanian, Macedonian, Malagasy, Malay, Malayalam, Maltese, Maori, Marathi, Mongolian, Myanmar (Burmese), Nepali, Norwegian, Persian, Polish, Portuguese, Punjabi, Romanian, Russian, Serbian, Sesotho, Sinhala, Slovak, Slovenian, Somali, Spanish, Sundanese, Swahili, Swedish, Tajik, Tamil, Telugu, Thai, Turkish, Ukrainian, Urdu, Uzbek, Vietnamese, Welsh, Yiddish, Yoruba, Zulu

Google Translate
Google Translate
Google Translate
Google Translate
Google Translate
Google Translate

Additional information

Updated : October 15, 2015
Size : Varies with device
Installs : 100,000,000 – 500,000,000
Current Version : Varies with device
Requires Android : Varies with device Content Rating : PEGI 3 Learn more
Permissions :

DOWNLOAD: Google Translate

download

About apk

Check Also

SEuvHUTwrVsn8BkWPNRM7ARYmAvxtJYdiQ8xOE6BmJ1wd0wODsgtMU5We1DUiPofebg

Tie A Scarf and Shawl Pro v1.61

Tie A Scarf and Shawl Pro v1.61 Requirements: 2.2 and up  Overview: Our application includes …

Leave a Reply